红联Linux门户
Linux帮助

更新Ubuntu 16.04系统中安装Adobe Flash更新失败的解决

发布时间:2018-03-08 09:53:22来源:mobibrw.com作者:默默的点滴
最近在更新 Ubuntu 16.04系统的时候,发现总是在安装 Adobe Flash更新的时候失败,提示如下信息:
 
正在处理用于 update-notifier-common (3.168.5) 的触发器 ...
flashplugin-installer: processing...
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20170912.1.orig.tar.gz
获取:1 http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20170912.1.orig.tar.gz [30.4 MB]
37% [1 /var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugi
已下载 30.4 MB,耗时 10分 11秒 (49.8 kB/s)                                     
W: 文件'/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170912.1.orig.tar.gz'无法被用户'_apt'访问,无法降低权限以进行下载。 - pkgAcquire::Run (13: 权限不够)
E: 下载失败
 
如果系统语言是英文的,可能看到下面的信息:
 
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170912.1.orig.tar.gz' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
 
解决方法如下:
 
$ sudo chown -R _apt:root /var/lib/update-notifier/package-data-downloads/partial/
$ sudo rm /var/lib/update-notifier/package-data-downloads/partial/*.FAILED
$ sudo apt install --reinstall update-notifier-common
$ sudo apt-get install --reinstall flashplugin-installer
 
这样就可以正常安装更新了。
 
Linux Mint下FireFox安装Adobe Flash Player:http://www.majhee.com/linux/24349.html
Ubuntu下自动更新Adobe flash player:http://www.majhee.com/linux/31769.html
Ubuntu下为Firefox安装Adobe Flash Player:http://www.majhee.com/linux/16823.html
更新Ubuntu Kylin源遇到问题(16.04中出现14.04相关源):http://www.majhee.com/linux/22266.html
更新Ubuntu自带的python2.X版本:http://www.majhee.com/linux/20606.html
时时彩开奖记录_重庆时时彩走势图_时时彩网上投注